CyberCat - Increased load on our mailserver – Incident details

All systems operational

Increased load on our mailserver

Resolved
Degraded performance
Started almost 2 years agoLasted 21 minutes

Affected

Mail services

Degraded performance from 1:25 PM to 1:45 PM

Mail server

Degraded performance from 1:25 PM to 1:45 PM

Updates
  • Resolved
    Resolved

    All services are now operating normaly.

  • Monitoring
    Monitoring

    The problem has been identified, the load has returned to normal. We are monitoring the situation.

  • Investigating
    Investigating

    We are currently experiencing an issue with our mailserver. We are investigating the situation and will keep you informed of any developments.